Back to overview
Degraded
Historical: Email Deliverability Issues
Mar 30 at 12:01pm AWST
Affected services
login.groupmap.com/health
login.eu.groupmap.com/health
Resolved
Mar 31 at 12:35pm AWST
Our email provider has resolved the delivery issues, emails are now being sent as expected
Affected services
login.groupmap.com/health
login.eu.groupmap.com/health
Created
Mar 30 at 12:01pm AWST
We are currently investigating an issue affecting email delivery for our platform. This may impact notification emails, password resets, and other system-generated messages. Our team is actively working to identify the root cause and implement a fix.
Affected services
login.groupmap.com/health
login.eu.groupmap.com/health